WaitOne is stack when outlook loads on "Send to" from explorer

Add-in Express™ Support Service
That's what is more important than anything else

WaitOne is stack when outlook loads on "Send to" from explorer
 
Igor Govorov




Posts: 83
Joined: 2014-02-12
Hi Guys,

In the Constructor of AddInFramework, that inherits from ADXAddinModule, I can't use WaitHandle.WaitOne() method because if the Outlook process closed and I use the "Send to" option (right click from explorer on file -> Send to) to send a mail, it hangs on WaitOne (with timeout) and doesn't get released until the UI is closed.

I reproduced the issue on Outlook 2013 and 2010.

So now I am forced to use native synchronization using WaitForSingleObject() (that works for me), is there a better way to solve it?
Posted 08 Jul, 2014 03:33:13 Top
Andrei Smolin


Add-in Express team


Posts: 17360
Joined: 2006-05-11
Hello Igor,

Can't say that I understand your goals. Plus, we haven't used WaitHandle.WaitOne() so we cannot recommend you anything.

FYI, if Outlook isn't running and you choose Send To | Mail Recipient in windows Explorer, this starts Outlook, creates the add-in module (the constructor is run) and shows the Inspector window modally. When you close the Inspector window, the add-in receives the AddinInitialize and AddinstartupComplete events (which means the add-in isn't loaded by Office until these events occur) and finally the Quit event of the Outlook.Application object.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 08 Jul, 2014 04:43:34 Top