Outlook Options Page Fails to load

Add-in Express™ Support Service
That's what is more important than anything else

Outlook Options Page Fails to load
 
Matt Driver


Matt


Posts: 152
Joined: 2004-08-17
Hi,

My Outlook Option Page displays the error: "Unable to display "POMI Options" page. This page will remain visible, but is not available" when the Add-in is installed with the setup.

If registered from VS2003 manually , it fails to works as well.

I have tried to create a new empty ADX project, added an empty option page, and the same problem remains. Also tried on another computer without success.

I am using VS2003 and Office 2003 but have VS2005 installed at same time. It was working a few days ago but I do not want to recreate the project.

I have followed the VSsetup.doc and it all looks correct I have ensured that the primary output is register = vsdrpCOM no other items have this selected. I have a shim. In the add-in I have "Registetrr for COm Interop as" FALSE

Any idea?

Thanks

Matt

Thomas
Posted 06 Jun, 2006 12:05:25 Top
Matt Driver


Matt


Posts: 152
Joined: 2004-08-17
I am using latest version of ADX and also the advanced demo OutlookProperyPageSetup works fine still so its my project build.

Matt
Posted 06 Jun, 2006 12:11:53 Top
Jim Albert




Posts: 21
Joined: 2005-12-31
Matt,

I had a similiar problem where my Options page would not load. I found that if I created an Addin without a C++ Shim my options page would work correctly.

Jim
Posted 06 Jun, 2006 19:30:41 Top
Matt Driver


Matt


Posts: 152
Joined: 2004-08-17
It worked fine for over a month but something has broken in the project.
Posted 07 Jun, 2006 04:49:52 Top
Matt Driver


Matt


Posts: 152
Joined: 2004-08-17
Hi

I have just recreated the entire project it only take 3 hours and it is all working so I don't know what happened to the project but I now have it working again. I thank the ADX team (or visual studio not sure which one) for allowing you to copy all the objects from one project and paste them into another it makes re-creation really quick.

Matt
Posted 07 Jun, 2006 06:14:16 Top
Sergey Grischenko


Add-in Express team


Posts: 7228
Joined: 2004-07-05
Hi Matt.

The cause of the issue could be in the PageProgID property of the addinmodule. Probably you had set the wrong prog ID.
Posted 07 Jun, 2006 06:46:58 Top