Error installing ADX based addin

Add-in Express™ Support Service
That's what is more important than anything else

Error installing ADX based addin
AddinExpress.Install.ADXProjectInstaller error... 
Michael McMahon




Posts: 56
Joined: 2005-05-03
Hi there,

I've been experiencing some issues with installing our office addin lately. What happens is the addin setup project builds okay but when you go to run the install on a client machine (other then the development machine) you get the following error message:

--------------------------- START OF ERROR ---------------------------

AddinExpress.Install.ADXProjectInstaller error: the add-in installation has fired an exception.

Where presumably this happened: Error occurred in the code of Add-in Express.NET Add-in Installer Library. See 'Details' section to get more detailed information about the error.

In the details you see the following:

Detailed technical information follows:
---
Date and Time: 5/24/2006 10:58:07 AM
Machine Name: OPEN-LDAL3FOKYV
IP Address: 192.19.1.67
Current User: OPEN-LDAL3FOKYV\Michael McMahon

Application Domain: DefaultDomain
Assembly Codebase: file:///C:/Program Files/Open Practice/OPD components/AddinExpress.Install.dll
Assembly Full Name: AddinExpress.Install, Version=2.5.1759.0, Culture=neutral, PublicKeyToken=null
Assembly Version: 2.5.1759.0
Assembly Build Date: 5/23/2006 4:58:26 PM

Exception Source: AddinExpress.Install
Exception Type: System.ApplicationException
Exception Message: An error occurred during the add-in registration process.
Exception Target Site: InstallAddin

---- Stack Trace ----
AddinExpress.Install.ADXProjectInstaller.InstallAddin(addinFullName As String, adxAssemblyName As String, check As String, gac As String, regasm As String)
AddinExpress.Install.dll: N 00245 (0xF5) JIT

--------------------------- END OF ERROR ---------------------------

I've tried a few things to resolve this like adding and removing the references to the AddinExpress dlls including the install dll in the setup (along with re-adding the custom data) however that hasn't seemed to resolve the issue.

Any thoughts on what I should do here?

Thanks in advance,


Michael McMahon
Posted 24 May, 2006 03:11:40 Top
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Hi Michael.

I tested your setup on my PCs (with Windows XP) and it was installed without any errors. I have just sent you the installer of your add-in built on my PC. Please test it.
Posted 24 May, 2006 07:18:52 Top
Michael McMahon




Posts: 56
Joined: 2005-05-03
Hi Sergey,

There have been some changes to the project since I sent it to you last. We are now using ADX version 2.5.1759.0.

I will send you our latest project / setup to test.


Mike
Posted 24 May, 2006 19:22:59 Top
Sergey Grischenko


Add-in Express team


Posts: 7235
Joined: 2004-07-05
Hi Mike.

Thanks. I have just received your email.
Posted 25 May, 2006 06:11:10 Top
Michael McMahon




Posts: 56
Joined: 2005-05-03
Hi Sergey,

Thanks for the solution you sent through by email! For readers of this topic... the problem was that I had commented out the following line in the AssemblyInfo.vb file of my project:

<Assembly: AssemblyKeyFileAttribute("..\..\OPpublicPrivateKeyFile.snk")>

Sergey said: "Please don't comment this code in future. It is needed for the shim."

Once again your support has been greatly appreciated!


Mike
Posted 25 May, 2006 18:45:40 Top