Error running converted installer on x86 computer

Add-in Express™ Support Service
That's what is more important than anything else

Error running converted installer on x86 computer
 
Paul Shaffer




Posts: 6
Joined: 2015-11-19
My vdproj to wix converted installer runs okay on x64 but I am getting this error on x86 machines. Perhaps you have run into this before. I can't find any fixes online.

Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor. Action CA_CreateConfig, entry: GetConfig, library: C:\Windows\Installer\MSI3867.tmp
=== Logging stopped: 3/21/2016 15:48:45 ===
Posted 21 Mar, 2016 17:02:40 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Paul,

Right now I cannot tell you the exact reason of this error. Could you please send the product.wxs file to me for testing? Also, what operating system is installed on those x86 machines?
Posted 22 Mar, 2016 06:35:14 Top
Paul Shaffer




Posts: 6
Joined: 2015-11-19
The problem appears to be due to some edits I made the the wix project after converting. I tried to change the bootstraps and .net framework versions myself.

Today I went back to the original vdproj, converted it, rebuilt, and I find the install works on my x86 win7 ultimate laptop. It must be something I did. I will have to compare the wixproj and wix files line by line to see what is different.

One problem is that the old vdproj in vs2010 refers to older .net and windows installer versions, and this results in a wix conversion in vs2013 with the old stuff in it.
Posted 22 Mar, 2016 10:20:39 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Paul,

Thank you for the additional information. I would suggest that you pay attention to the following binary:

  <Binary Id="InstallUtilConfig" SourceFile="ResourcesBinaryInstallUtilConfig" />


It should be included in your installation package, as far as I understand the CA_CreateConfig action cannot find it in your msi package.
Posted 22 Mar, 2016 11:26:17 Top
Paul Shaffer




Posts: 6
Joined: 2015-11-19
The resources/binary files were for x64. I changed them to x86 versions and the install works now on x86.

What is the purpose of the add-in express binaries ConfigUtil and adxdpca.dll? Does the installer always need these?
Posted 23 Mar, 2016 11:43:31 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Paul,

Thank you for the details, I will try to find the cause of the issue.

What is the purpose of the add-in express binaries ConfigUtil and adxdpca.dll? Does the installer always need these?


The adxdpca.dll is a native C++ library that is used as an MSI custom action. For example, it is used in Web Setup projects for gathering information about existing web sites and app pools, it is also used for launching .NET custom actions. InstallUtil and InstallUtilConfig are required to run .NET custom actions.
Posted 24 Mar, 2016 05:12:54 Top