WiX Designer - Empty WiX Editor windows

Add-in Express™ Support Service
That's what is more important than anything else

WiX Designer - Empty WiX Editor windows
 
JanFrost




Posts: 24
Joined: 2008-07-01
For whatever reason the WiX Designer is only showing empty editor windows.
Either using the buttons in the solution explorer or using the View menu - View WiX Editors only a tab is opened but it is empty.
I already tried unsinstalling and reinstalling the AddIn. Without success.
Posted 14 Oct, 2014 08:05:38 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Jan,

Please use the link below to download a hotfix. You need to replace assemblies located in the ‘VS2010’,
‘VS2012’ and ‘VS2013’ subfolders of the designer installation directory with the new assemblies from the archive.
http://www.add-in-express.com/tmp/hotfix-1.2.197.0.zip

You may not have all these subfolders. It depends on what versions of Visual Studio you have installed on your PC. Don’t forget to unlock the .zip file before you unzip it (right click on hotfix-1.2.197.0.zip in Windows Explorer and press the Unlock button).
Posted 14 Oct, 2014 14:04:26 Top
JanFrost




Posts: 24
Joined: 2008-07-01
Hi Sergey,

installed the file, started visual studio, working!
Thanks for the great support!

Regards,
Jan
Posted 15 Oct, 2014 02:11:26 Top
JanFrost




Posts: 24
Joined: 2008-07-01
Hi Sergey,

having issues with the xml files created from the 'Add project output' command. Every output node (Binaries, Symbols, Sources, Content, Sattelites, Documents) has the 'SelfRegCost' parameter set to 0. I guess it should be left empty.
Not sure if it's related to the hotfix version above. I did not have the issues before, though.

Regards,
Jan

P.S.: By the way. You may want to check the ManufacturerURL and SupportURL property from the setup properties. The are mapped to ARPURLINFOABOUT and ARPHELPLINK but mixed up.

P.S.S.: When I have a solution folder 'Server' and inside is a project 'Server'. Then I create as WiX setup project (not in the solution folder). When adding project output in the file system window the dropdown box project says 'Server (Server\Server)' wehere it normally just gives the project name without the brackets. Adding the project output is not working then. Maybe you can reproduce that.
Posted 15 Oct, 2014 09:38:11 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Jan,

I can't reproduce it. Do you have VDProjToWiX converter installed? If so, what version?
As to ManufacturerURL and SupportURL properties, they are correct. Please look at the 'Control Panel -> Programs and Features' dialog. You will see the support link in the 'Support Link' column.
Posted 15 Oct, 2014 10:03:07 Top
JanFrost




Posts: 24
Joined: 2008-07-01
VDProj to WiX Converter is Version 1.4.129. It was not used for this Setup, though.
Posted 15 Oct, 2014 10:34:01 Top
JanFrost




Posts: 24
Joined: 2008-07-01
Did you try the hotfix assembly when reproducing the issue with the SelfRegCost?

Your 'ManufacturerURL' is written to the 'ARPHELPLINK' property which '...is the Internet address for technical Support.' (msdn ARPHELPLINK)

Your 'SupportURL' is written to the 'ARPURLINFOABOUT' property which '...is the URL for the link to the publishers home page or the application's home page.' (msdn ARPURLINFOABOUT)

The display in the 'Programs and Features' dialog is strange though. There is a comment about that at the given URLs.

Did you see the third issue I appended? Not sure if you can reproduce that but I had it in two Projects.

Anyway, I can work around all these. Just wanted to mention them.
Posted 16 Oct, 2014 02:43:44 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Jan,

The hotfix contains the latest assemblies. We use to have this issue in the old version of the VDProjToWiX converter. Please try to disable the converter in Add-in Manager. Or just install the latest version.

I saw the documentation for the MSI properties. I just wanted to support 'Programs and Features' correctly.

I can't reproduce the third issue. What is type of the Server project? Is it an .exe, .dll or a web project?
Posted 16 Oct, 2014 05:42:29 Top