«Setup doesn't register toolbar» Continued

Add-in Express™ Support Service
That's what is more important than anything else

«Setup doesn't register toolbar» Continued
Toolbar is not being registered 
Theodore Forsman




Posts: 1
Joined: 2011-09-15
We have used Add-in Express to create browser extensions for over a year and have been generally satisfied with its performance. However, with our most recent browser extension, we are experiencing installation problems.
Furthermore, we are having a difficult time diagnosing the root cause. Here are the facts:

1. On the majority of installations (via the msi file alone) there are no issues. This is the case for all tested combinations of operating system (Vista/Windows 7) and browser version (IE 8/9).

2. On some installations, the path to successful installation is via using setup.exe in conjunction with the msi file. Again, this applies for all tested combinations of operating system (Vista/Windows 7) and browser version (IE 8/9).

3. On some other installations, the browser extension does NOT show up in the browser, i.e., it does not show when clicking the "Gear" Icon > Toolbars, or Tools > Manage Add-ons. This happens regardless of whether installation is attempted via the msi file alone, or via the setup.exe in conjunction with the msi file. Again, this applies for all tested combinations of operating system (Vista/Windows 7) and browser version (IE 8/9). However, the extension shows up in the list of installed programs (Control Panel > Uninstall). We have been unsuccessful in getting it to show up in the browser.

This appears to be related to the top <<Setup doesn't register toolbar>> from June 3, 2011. Please reply with a set of detailed instructions to follow on a computer on which the toolbar does not install. For example,

Should we be checking the Windows registry?
If so, for what should we be looking?
What, if any, workaround is there for the problem?

It is clear that this is not a problem with the Toolbar code, as it installs on 95% or more of computers without a problem. So please do not reply and ask for the source code, as that would indicate that you do not understand the problem. If that is what you think you need, then please check with others in support so as to correctly understand the problem. We have brought this item to the attention of Eugene Astafiev, but he wants the source code and that is not the problem. Or, please explain what you would look for in the source code to help you identify the problem. We will then check the source code on our side.

In conclusion, this is an installation problem. Once again, this is an installation problem, not a code problem. So please help by telling us what to investigate on the computer on which the toolbar will not install.
Posted 15 Sep, 2011 18:07:32 Top
Sergey Grischenko


Add-in Express team


Posts: 7228
Joined: 2004-07-05
Hi Theodore,

Do you use adxregistrator.exe to register the add-on?
If so, please send me the adxregistrator.log file from the problematic PC.
Posted 16 Sep, 2011 09:31:54 Top