IE BHO does not load on a specific computer with Windows 7, x64

Add-in Express™ Support Service
That's what is more important than anything else

IE BHO does not load on a specific computer with Windows 7, x64
 
Stan S




Posts: 181
Joined: 2007-09-04
I purchased ADX for IE a few days ago and downloaded recent version of it.
Version of ADXLoader: 6.0.3037.0

I create add-in (BHO) for IE, it is very basic at this moment. I have positive report fr om my client's test lab where they check it with Windows 7 x64 bit (probably default configuration). I had negative report from a end user. The end user had reported that our previous unmanaged BHO did not work with him (that's why we purchased ADX for .NET and tried to create version of the plugin with managed code). So the new ADX-drived BHO did not work.

I discovered that he had UAC slider at the "minimum" position. So I advised that he sets UAC to maximum (default position), reboot computer and reinstalled the plugin. He did all of that but did not help.

The logs look good, I paste them here for your convenience:

Add-in Express Registrator Log File: 05/12/2010 17:09:42

Installation directory: C:\Program Files (x86)\Default Company\SOMETHING\
Registrator version: 6.0.1.0
-------------------------------
17:09:42 Starting the add-in registration process.
17:09:42 Loading mscoree.dll
17:09:42 Success.
17:09:42 .NET Framework installation directory:
17:09:42 The latest version of .NET Framework: 'v2.0.50727'
17:09:42 Loading CLR: v2.0.50727.
17:09:42 The CLR v2.0.50727 has been initialized successfully.
17:09:42 Creating a new domain setup.
17:09:42 Success.
17:09:42 Getting the add-in directory.
17:09:42 Success. The directory is 'C:\Program Files (x86)\Default Company\SOMETHING
17:09:42 The configuration file is '(null)'
17:09:42 The 'shadow copy' is disabled.
17:09:42 Creating a new application domain.
17:09:42 Success.
17:09:42 Getting the base directory for the domain.
17:09:42 Success. The directory is 'C:\Program Files (x86)\Default Company\SOMETHING\'.
17:09:42 Searching for the Add-in Express core library.
17:09:42 Success. The 'AddinExpress.IE.dll' file is found.
17:09:42 Creating an instance of the 'AddinExpress.Deployment.ADXRegistrator' class.
17:09:42 Assembly identity is 'AddinExpress.IE'.
17:09:58 Success.
17:09:58 Unwrapping the instance of the 'AddinExpress.Deployment.ADXRegistrator' class.
17:09:58 Success.
17:09:58 Calling the managed registration procedure.
17:09:58 Success.
17:09:58 The add-in registration process is completed with HRESULT = 0.

When I go to the "Manage Addons", we can see the BHO as addon, however it has empty cell in "Load time (sec)" column, indicated it hasn't been loaded. We don't have any other logs.

Rebooting computer does not help, system is up-to-date.

Can you advise please?

Stan
Posted 18 May, 2010 12:56:04 Top
Sergey Grischenko


Add-in Express team


Posts: 7205
Joined: 2004-07-05
Hi Stan.

Please check if the "Enable third-party browser extensions" option is checked in Internet Options on the problematic PC.
Posted 19 May, 2010 07:03:56 Top
Stan S




Posts: 181
Joined: 2007-09-04
Whoa! It was off indeed. Now it works like a charm, thank you!
Posted 19 May, 2010 09:35:29 Top
Sergey Grischenko


Add-in Express team


Posts: 7205
Joined: 2004-07-05
Good luck, Stan.
Posted 19 May, 2010 10:10:42 Top