toolbar doesn't show up on start up

Add-in Express™ Support Service
That's what is more important than anything else

toolbar doesn't show up on start up
 
Sushil Pandey




Posts: 3
Joined: 2010-04-23
The toolbar doesn't show up on the start of the internet explorer (IE8, windows xp). Everytime I have to view>toolbar>my toolbar. And when I create a new tab again i have to enable it from the menu.i also checked this topic and did the same but no luck. Heres my code of IEmodule.cs




using System;
using System.Runtime.InteropServices;
using System.ComponentModel;
using System.Windows.Forms;
using IE = Interop.SHDocVw;

namespace MyIEAddon1
{
/// <summary>
/// Add-in Express for Internet Explorer Module
/// </summary>
[ComVisible(true), Guid("BFA1F247-16A1-40CE-B4D8-85779D9FB99F")]
public class IEModule : AddinExpress.IE.ADXIEModule
{
private AddinExpress.IE.ADXIEToolBarItem adxieToolBarItem1;

public IEModule()
{
InitializeComponent();
}

public IEModule(IContainer container)
{
container.Add(this);

InitializeComponent();
}

#region Component Designer generated code
/// <summary>
/// Required by designer
/// </summary>
private System.ComponentModel.IContainer components;

/// <summary>
/// Required by designer support - do not modify
/// the following method
/// </summary>
private void InitializeComponent()
{
this.components = new System.ComponentModel.Container();

this.adxieToolBarItem1 = new AddinExpress.IE.ADXIEToolBarItem(this.components);
//
// adxieToolBarItem1
//
this.adxieToolBarItem1.ToolBarType = "MyIEAddon1.MyIEToolBar1";
this.adxieToolBarItem1.LoadAtStartup = true;
this.adxieToolBarItem1.MenuText = "My Toolbar";
this.adxieToolBarItem1.Position = AddinExpress.IE.ADXIEToolBarPosition.tbpNewRow;
this.adxieToolBarItem1.Title = "My Toolbar";
//
// IEModule
//
this.ModuleName = "MyIEAddon1";
this.ToolBars.Add(this.adxieToolBarItem1);
}


#endregion

#region ADX automatic code

// Required by Add-in Express - do not modify
// the methods within this region

public override System.ComponentModel.IContainer GetContainer()
{
if (components == null)
components = new System.ComponentModel.Container();
return components;
}

[ComRegisterFunctionAttribute]
public static void RegisterIEModule(Type t)
{
AddinExpress.IE.ADXIEModule.RegisterIEModuleInternal(t);
}

[ComUnregisterFunctionAttribute]
public static void UnregisterIEModule(Type t)
{
AddinExpress.IE.ADXIEModule.UnregisterIEModuleInternal(t);
}

[ComVisible(true)]
public class IECustomContextMenuCommands :
AddinExpress.IE.ADXIEModule.ADXIEContextMenuCommandDispatcher
{
}

[ComVisible(true)]
public class IECustomCommands :
AddinExpress.IE.ADXIEModule.ADXIECommandDispatcher
{
}

#endregion

public IE.WebBrowser IEApp
{
get
{
return (this.IEObj as IE.WebBrowser);
}
}

public mshtml.HTMLDocument HTMLDocument
{
get
{
return (this.HTMLDocumentObj as mshtml.HTMLDocument);
}
}


}
}
Posted 23 Apr, 2010 09:50:11 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Sushil.

Please open IE again and send me the adxloader.log file created by the loader in the '.\MyDocuments\Add-in Express' directory.
Posted 23 Apr, 2010 10:26:24 Top
Sushil Pandey




Posts: 3
Joined: 2010-04-23
heres the log file:

Add-in Express Loader Log File: 04/23/2010 11:23:04

Startup directory: C:\Documents and Settings\Spandey\Desktop\MyIEAddon1\MyIEAddon1\bin\Debug\
Loader version: 6.0.3037
IE Protected Mode: Off
------------------
11:23:04 1060 548 Start.
11:23:04 1060 548 Reading the registry key 'HKEY_CLASSES_ROOT\CLSID\{BFA1F247-16A1-40CE-B4D8-85779D9FB99F}'
11:23:04 1060 548 Success. The registry key 'HKEY_CLASSES_ROOT\CLSID\{BFA1F247-16A1-40CE-B4D8-85779D9FB99F}' is closed.
11:23:04 1060 548 Converting the '{A3A5C6A6-288F-4eee-8634-2BA9D5A28002}' CLSID from string.
11:23:04 1060 548 Success.
11:23:04 1060 548 Attempting to get the class object by the '{A3A5C6A6-288F-4eee-8634-2BA9D5A28002}' CLSID.
11:23:04 1060 548 Success.
11:23:04 1060 548 Creating a new instance of the add-on loader.
11:23:04 1060 548 Success.
11:23:04 1060 548 Loading the configuration from the system registry.
11:23:04 1060 548 Getting the latest CLR version.
11:23:04 1060 548 The latest CLR version is 'v2.0.50727'.
11:23:04 1060 548 The configuration has been loaded successfully.
11:23:04 1060 548 Runtime version: v2.0.50727.
11:23:04 1060 548 Assembly name: MyIEAddon1, PublicKeyToken=61BF7E739A0C20C7.
11:23:04 1060 548 Class name: MyIEAddon1.IEModule.
11:23:04 1060 548 Attempting to create a new instance of the managed add-on class: CLR - v2.0.50727
11:23:04 1060 548 Loading CLR: v2.0.50727.
11:23:04 1060 548 The CLR v2.0.50727 has been initialized successfully.
11:23:04 1060 548 Creating a new domain setup.
11:23:04 1060 548 Success.
11:23:04 1060 548 Getting the add-in directory.
11:23:04 1060 548 Success. The directory is 'C:\Documents and Settings\Spandey\Desktop\MyIEAddon1\MyIEAddon1\bin\Debug\'
11:23:04 1060 548 The configuration file is 'C:\Documents and Settings\Spandey\Desktop\MyIEAddon1\MyIEAddon1\bin\Debug\MyIEAddon1.dll.config'
11:23:04 1060 548 The 'shadow copy' is enabled.
11:23:04 1060 548 Creating a new application domain.
11:23:04 1060 548 Success.
11:23:05 1060 548 Unwrapping the managed class.
11:23:05 1060 548 Success.
11:23:05 1060 548 Querying the ObjectWithSite interface.
11:23:05 1060 548 Success.
11:23:05 1060 548 Getting the dispid of the 'Dispose' method.
11:23:05 1060 548 Success.
11:23:05 1060 548 Getting the dispid of the 'InitializeModule' method.
11:23:05 1060 548 Success.
11:23:05 1060 548 Getting the dispid of the 'InitializeLoaderAPI' method.
11:23:05 1060 548 Success.
11:23:05 1060 548 The managed add-on class has been created successfully.
11:23:12 1060 548 Start.
11:23:12 1060 548 Reading the registry key 'HKEY_CLASSES_ROOT\CLSID\{525BAA5B-B753-427A-BE7C-053258411A3C}'
11:23:12 1060 548 Success. The registry key 'HKEY_CLASSES_ROOT\CLSID\{525BAA5B-B753-427A-BE7C-053258411A3C}' is closed.
11:23:12 1060 548 Converting the '{9FDA82EE-02B9-4e29-98D5-64B872B6F4EA}' CLSID from string.
11:23:12 1060 548 Success.
11:23:12 1060 548 Attempting to get the class object by the '{9FDA82EE-02B9-4e29-98D5-64B872B6F4EA}' CLSID.
11:23:12 1060 548 Success.
11:23:12 1060 548 Creating a new instance of the add-on loader.
11:23:12 1060 548 Success.
11:23:12 1060 548 Loading the configuration from the system registry.
11:23:12 1060 548 Getting the latest CLR version.
11:23:12 1060 548 The latest CLR version is 'v2.0.50727'.
11:23:12 1060 548 The configuration has been loaded successfully.
11:23:12 1060 548 Runtime version: v2.0.50727.
11:23:12 1060 548 Assembly name: MyIEAddon1, PublicKeyToken=61BF7E739A0C20C7.
11:23:12 1060 548 Class name: MyIEAddon1.MyIEToolBar1.
11:23:12 1060 548 Attempting to create a new instance of the managed add-on class: CLR - v2.0.50727
11:23:12 1060 548 Unwrapping the managed class.
11:23:13 1060 548 Success.
11:23:13 1060 548 Querying the ObjectWithSite interface.
11:23:13 1060 548 Success.
11:23:13 1060 548 Querying the IInputObject interface.
11:23:13 1060 548 Success.
11:23:13 1060 548 Querying the IDeskBand interface.
11:23:13 1060 548 Success.
11:23:13 1060 548 Getting the dispid of the 'Dispose' method.
11:23:13 1060 548 Success.
11:23:13 1060 548 Getting the dispid of the 'InitializeToolbar' method.
11:23:13 1060 548 Success.
11:23:13 1060 548 Checking the dispid of the 'GetToolbarCount' method.
11:23:13 1060 548 Success.
11:23:13 1060 548 The managed toolbar class has been created successfully.
Posted 23 Apr, 2010 10:30:39 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
All is Ok. The toolbar is loaded at the same time with the add-on and it should be visible in IE.
Posted 23 Apr, 2010 11:00:00 Top
Sushil Pandey




Posts: 3
Joined: 2010-04-23
Something in my IE was causing it not to show on load. I did a reset on my IE and now its working fine.
Posted 23 Apr, 2010 14:49:22 Top
Andrei Smolin


Add-in Express team


Posts: 14356
Joined: 2006-05-11
Hi Sushil,

Thank you for letting us know.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 26 Apr, 2010 05:50:22 Top