AddinExpress.IE.Wizard.Resources.resources

Add-in Express™ Support Service
That's what is more important than anything else

AddinExpress.IE.Wizard.Resources.resources
Could not find resources appropriate for the specified culture or the neutral culture. 
Shawn Fenus




Posts: 16
Joined: 2010-01-08
Hi,

I am getting the mscorlib error after each time I publish:

Could not find resources appropriate for the specified culture or the neutral culture. Make sure "AddinExpress.IE.Wizard.Resourced.resources" was correctly embedded or linked into the assembly "AddinExpress.IEWizard" at compile time, or that all the satellite assemblies required are loaded and fully signed.

It does this after the publish is complete and so far I have not seen it impact anything but is there anything I can do to make this go away? I will be starting on Code Signing shortly (Will this help?)

OS: XP
Visual Studio 2008
Version 9.0.21022.8 RTM
Version3.5 SP1

adxloader.dll version: 6.0.3035.0
AddinExpress.IE.dll: 6.0.365.0


Thanks in Advance
Posted 01 Mar, 2010 20:45:06 Top
Dmitry Kostochko


Add-in Express team


Posts: 2740
Joined: 2004-04-05
Hi Shawn,

Please try to install SP1 for Visual Studio 2008 and the latest version of Add-in Express for Internet Explorer and .NET.
Posted 02 Mar, 2010 08:21:52 Top
Shawn Fenus




Posts: 16
Joined: 2010-01-08
Thanks for catching that - Just switched to this machine and had not realized that was not installed. However I am still getting the same error. I made sure I have all my windows updates too.

I did not think it had much of an impact - but I just deployed to testing and I started getting an FileCannotBeFound error for the Microsoft.mshtml.dll.

After upgrading to 2010 I created a new build using the "Create Setup Project" on the Context Menu of the project. It created the project without including the Microsoft.mshtml.dll in the my setup project.

I manually put it back in the application folder of the setup project as it was in my previous setup project and now the Document_OnComplete is not firing on the test machines.

Could the error documented in this thread be causing this problem?

NOTE:
I also created another sidebar project (just for testing purposes) and ran the "Create Setup Project" - It created the Microsoft.mshtml just as it had done before in the IE Add-in Express 2009.

Also - I download the sidebar project on my development box and everything runs fine. It's as if it is not registering it on the test machine during install.




Thanks,
Shawn
Posted 04 Mar, 2010 13:57:06 Top
Shawn Fenus




Posts: 16
Joined: 2010-01-08
Hi Dmitry,

I removed my setup project for my sidebar completely and ran the wizard again with the identical results. It did not include the Microsoft.mshtml.dll.


Thanks
-Shawn
Posted 04 Mar, 2010 14:10:12 Top
Shawn Fenus




Posts: 16
Joined: 2010-01-08
Hi Dmitry,

Just noticed this also - when I create a completely new sidbar project with Add-In Express and create a setup project for it the error (below) does not appear - it just appears in the the project I already had before I upgraded to Add-In Express 2010 from 2009. I am in the process of creating it from scratch in Add-In Express 2010 now to see if that fixes the problem.

"Could not find resources appropriate for the specified culture or the neutral culture. Make sure "AddinExpress.IE.Wizard.Resourced.resources" was correctly embedded or linked into the assembly "AddinExpress.IEWizard" at compile time, or that all the satellite assemblies required are loaded and fully signed. "

Thanks,
-Shawn
Posted 04 Mar, 2010 17:37:35 Top
Andrei Smolin


Add-in Express team


Posts: 14358
Joined: 2006-05-11
Hi Shawn,

Can we look at your project? If this is possible, please send it to the support e-mail address (see readme.txt). Make sure that your e-mail contains a link to this topic.

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 09 Mar, 2010 09:43:26 Top
Shawn Fenus




Posts: 16
Joined: 2010-01-08
Hi Andrei,

I had not realized there was a response to this - Just happened across this forum thread today. I got around the "FileCannotBeFound error on the Microsoft.mshtml.dll." problem described in this forum thread though. I do not know why but after I removed The Primary output in the setup project and and then added it in again this fixed the problem. The problem occurred when I upgraded from 2009 to 2010. Hope this can help someone.


Also (THANKS) the following error disapeared after I installed "SP1 for Visual Studio 2008":

"Could not find resources appropriate for the specified culture or the neutral culture. Make sure "AddinExpress.IE.Wizard.Resourced.resources" was correctly embedded or linked into the assembly "AddinExpress.IEWizard" at compile time, or that all the satellite assemblies required are loaded and fully signed. "

-Shawn
Posted 18 Mar, 2010 17:49:20 Top
Andrei Smolin


Add-in Express team


Posts: 14358
Joined: 2006-05-11
Hi Shawn,

Thank you very much!

Regards from Belarus (GMT+2),

Andrei Smolin
Add-in Express Team Leader
Posted 19 Mar, 2010 06:55:01 Top