Default Install continues to be C:\

Add-in Express™ Support Service
That's what is more important than anything else

Default Install continues to be C:\
I am using the integrated WiX setup project builder.. 
matt zamora




Posts: 3
Joined: 2015-02-06
I am a total nube. I just completed my first IE addon. I followed the tutorial on line to create a WiX setup project but it seems like no matter what I try the default folder listed in the MSI is C:\. Is there a way to hard code this to the [ProgramFilesFolder][Manufacturer]\[ProductName] ?
Posted 06 Feb, 2015 07:24:28 Top
Andrei Smolin


Add-in Express team


Posts: 14106
Joined: 2006-05-11
Hello Matt,

The simplest way is to let Add-in Express generate a WiX project for you. Select your add-in project and then click Create Project on the Project menu; in the Wizard window choose WiX.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 06 Feb, 2015 08:14:38 Top
matt zamora




Posts: 3
Joined: 2015-02-06
Yes this is what I have done following the posted tutorial. Addin Express created the WiX setup. but the install dialogue always defaults to C:\
Posted 06 Feb, 2015 08:20:03 Top
Andrei Smolin


Add-in Express team


Posts: 14106
Joined: 2006-05-11
Matt,

If you create a new setup project and start the installer, will it point to C:\?

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 06 Feb, 2015 08:55:07 Top
matt zamora




Posts: 3
Joined: 2015-02-06
Yes. I have tried several times. It always defaults to C:\. I have removed the startup project deleted it, cleaned the project added a new startup project in a different folder and it still recompiles to a default of C:\.


This is the install Sequence it is generating:
<InstallExecuteSequence>
<Custom Action="DIRCA_TARGETDIR" Before="CostInitialize"><![CDATA[TARGETDIR=""]]></Custom>
<Custom Action="DIRCA_TARGETDIR_UNINSTALL" After="AppSearch"><![CDATA[PREVIOUSINSTALLFOLDER]]></Custom>
<Custom Action="PreventDowngrading" After="FindRelatedProducts"><![CDATA[NEWPRODUCTFOUND]]></Custom>
<Custom Action="_E33A7ABB_2FD5_498A_9585_E6AF103062CC" After="StartServices"><![CDATA[$comp_871B06F8_702F_4641_B5C0_98D18443F5D2>2]]></Custom>
<Custom Action="_83E082B0_7CF2_4163_9C51_7A58DE8BA5B9" After="_E33A7ABB_2FD5_498A_9585_E6AF103062CC"><![CDATA[$comp_871B06F8_702F_4641_B5C0_98D18443F5D2>2]]></Custom>
<Custom Action="_41A6048C_E334_4BAD_8173_E549D451CCE0" After="MsiUnpublishAssemblies"><![CDATA[$comp_871B06F8_702F_4641_B5C0_98D18443F5D2=2]]></Custom>
<RemoveExistingProducts Before="InstallInitialize" />
</InstallExecuteSequence>
<InstallUISequence>
<FindRelatedProducts Sequence="200" />
<Custom Action="DIRCA_TARGETDIR" Before="CostInitialize"><![CDATA[TARGETDIR=""]]></Custom>
<Custom Action="DIRCA_TARGETDIR_UNINSTALL" After="AppSearch"><![CDATA[PREVIOUSINSTALLFOLDER]]></Custom>
<Custom Action="PreventDowngrading" After="FindRelatedProducts"><![CDATA[NEWPRODUCTFOUND]]></Custom>
</InstallUISequence>

And TARGETDATA is set to Property="TARGETDIR" Value="[ProgramFilesFolder][Manufacturer]\[ProductName]" Execute="firstSequence"
Posted 06 Feb, 2015 09:11:18 Top
Andrei Smolin


Add-in Express team


Posts: 14106
Joined: 2006-05-11
Hello Matt,

I've created a solution containing a single project - a new Add-in Express project; in fact this always occurs when you create a new Add-in Express project. Then I let Add-in Express create a WiX setup project. Here's what is written in Product.wxs for me:

    <CustomAction Id="PreventDowngrading" Error="Newer version already installed." />
    <Binary Id="adxregistrator_exe" SourceFile="$(var.ADX_PATH)Redistributablesdxregistrator.exe" />
    <!-- The "adxregistrator.exe" custom action. -->
    <CustomAction Id="_5A1BB556_56C9_4053_BA3A_AD4D78E8A780" BinaryKey="adxregistrator_exe" Execute="deferred" ExeCommand="/install=&quot;[TARGETDIR]$(var.MyIEAddon7.TargetFileName)&quot; /privileges=admin" Impersonate="yes" />
    <!-- The "adxregistrator.exe" custom action. -->
    <CustomAction Id="_79D327A7_9340_4E9E_900A_ECFD33A1A6DB" BinaryKey="adxregistrator_exe" Execute="rollback" ExeCommand="/uninstall=&quot;[TARGETDIR]$(var.MyIEAddon7.TargetFileName)&quot; /privileges=admin" Impersonate="yes" />
    <!-- The "adxregistrator.exe" custom action. -->
    <CustomAction Id="_EA20F68F_4CC0_482E_B993_AC08AC0B26F5" BinaryKey="adxregistrator_exe" Execute="deferred" ExeCommand="/uninstall=&quot;[TARGETDIR]$(var.MyIEAddon7.TargetFileName)&quot; /privileges=admin" Impersonate="yes" />
    <!-- Initialize the "TARGETDIR" directory property. -->
    <CustomAction Id="DIRCA_TARGETDIR" Property="TARGETDIR" Value="[ProgramFilesFolder][Manufacturer][ProductName]" Execute="firstSequence" />


Since your code doesn't mention adxregistrator.exe, it looks like you create the setup project in some other way. Please use the Setup Project Wizard, find the section of the same name in the manual, see the PDF file in the folder {Add-in Express}\Docs on your development PC.

I don't understand what you talk about the startup project either.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 09 Feb, 2015 03:44:31 Top