Installation error during Add-In Express installation

Add-in Express™ Support Service
That's what is more important than anything else

Installation error during Add-In Express installation
 
Vlad Kuz




Posts: 3
Joined: 2014-01-03
Hello,

I am having a problem installing the Add-in Express .NET for IE. When I run setup.exe (I use the Run as Administrator option), I am getting an error message, after which all installation rolls back.

The error message is "The process cannot access the file 'c:\Program Files (x86)\Add-in Express\Add-In Express .NET for Internet Explorer\Bin\AddinExpress.IE.dll' because it is being used by another process."
The error appears during the Registering phase.

User added an image

I tried to find the dll using Process Explorer (SysInternals) and it showed it was not used by any process.

I use Windows 8, 64 bit.

Please help,

Thanks,
Vlad.
Posted 03 Jan, 2014 14:19:43 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Vlad,

I have noticed a strange difference between the content of your screenshot and the text of the error message you provided. On the screenshot, I see "Add-in Express for IE" folder but in your description it is "Add-In Express .NET for Internet Explorer". Please make sure you don't have any previous version of our product installed on your machine.
Posted 04 Jan, 2014 06:34:28 Top
Vlad Kuz




Posts: 3
Joined: 2014-01-03
Hi Dmitry,

I have made several attempts to install and during one of the attempts I tried to change the folder name, thinking it would help. It didn't. The screenshot was made during another attempt.

It is a brand new machine, so there are no previous versions. In fact, I am trying to setup a development environment and all is done except the AddIn Express. I have rebooted the machine several times - the error is still the same.
Posted 05 Jan, 2014 23:48:43 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Vlad,

Thank you for the details. Please try to do the following:

- make sure you are an administrator on the PC.

- on Vista, Windows 7 - 8 and Windows 2008 Server, set UAC to its default level.

- in Control Panel -> System -> Advanced -> Performance -> Settings -> Data Execution Prevention, set the "... for essential Windows programs and services only" flag.

- remove the following registry key, if it exists:
HKCU\Software\Add-in Express\{product identifier} {version} {package}

- run setup.exe, not .MSI. If this is applicable, run setup.exe by right clicking it and choosing "Run as administrator" in the context menu.

- finally, use the Automatic Activation option in the installer windows.

Also, I can assume that your antivirus or some protection software may temporary block access to the assembly for some reason. Please turn it off before installation. Please let me know about the results in any case.
Posted 06 Jan, 2014 05:29:17 Top
Vlad Kuz




Posts: 3
Joined: 2014-01-03
Hi Dmitry,

Turning off the antivirus did the trick.

Thank you very much,
Vlad.
Posted 06 Jan, 2014 11:41:55 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Vlad,

Thank you for good news!
Posted 07 Jan, 2014 03:20:14 Top