Context Menu Not Showing in Server 2012

Add-in Express™ Support Service
That's what is more important than anything else

Context Menu Not Showing in Server 2012
My add-in generates context menus which show in all versions of Windows and IE we've tested except on Windows Server 2012 
Ira Whitman




Posts: 54
Joined: 2010-01-21
My problem may be the same as that described in another post which was created and resolved about one year ago: Context Menu Not Showing...

My add-in seems to work in both 32bit and 64bit Internet Explorer versions 8, 9, and 10 on various operating systems from XP to Windows 8, but the context menu items are not present on IE 10 on Windows Server 2012.

The add-in is listed and enabled in Add-In Manager. The adxloader.log shows successful load.

Everything seems identical to our working Windows 8 machines, which work.

But on Server 2012, our menu items are not displayed in the IE context menu.
Posted 30 Oct, 2013 08:33:03 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Ira,

What version of Add-in Express for IE do you use?
Posted 30 Oct, 2013 09:35:39 Top
Ira Whitman




Posts: 54
Joined: 2010-01-21
It is version 8.2.5067.

Also, I think we've come upon some additional info.
Our add-in is 32 bit (it uses a couple of COM objects). On Windows 7 and 8 x64 systems, we see two entries for Internet Explorer in Task Manager: one is 64 bit and the other ix 32 bit. Research has told us that even when launched as a 64-bit app, IE 10 runs a 32-bit process for hosting 32-bit content. (http://blogs.msdn.com/b/ieinternals/archive/2012/03/23/understanding-ie10-enhanced-protected-mode-network-security-addons-cookies-metro-desktop.aspx). But this doesn't seem to be true on Server 2012. On our Server 2012 machine, there is a single IE 10 process, which is 64 bit. It is not surprising, then, that our 32 bit add-in doesn't run.

We've tried altering the Enhanced Protected Mode setting but this hasn't had an affect: IE 10 is still 64-bit only.
Posted 31 Oct, 2013 10:21:17 Top
Ira Whitman




Posts: 54
Joined: 2010-01-21
One of our QA engineers found the issue and solution. On Windows Serve 2012, there is a feature called Internet Explorer Enhanced Security Configuration (IE ESC) that is enabled/disabled through the Server Manager. By default, it is on for both Administrators and other Users. It is necessary to turn this off in order for our 32 bit add-on to load in 64 bit IE 10 on Server 2012.
Posted 31 Oct, 2013 12:29:16 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Ira,

Add-in Express for IE v8.2 doesn't support Enhanced Protected Mode (EPM). Please use the latest version of the product: v8.3.5068.
Posted 01 Nov, 2013 06:49:09 Top
Ira Whitman




Posts: 54
Joined: 2010-01-21
Oh, thank you for the additional info. Please let me ask:

Would EPM support in 8.3.5068 be limited to projects built for "Any CPU"? My project is limited to x86 due to COM components.
Posted 01 Nov, 2013 09:09:59 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Ira,

IE (with EPM is turned on) doesn't load add-ons built for one platform. To support EPM you need to register your add-on for both platforms (if the target OS is x64-based).
Posted 01 Nov, 2013 09:32:06 Top