iemodule design mode error

Add-in Express™ Support Service
That's what is more important than anything else

iemodule design mode error
 
minho so




Posts: 11
Joined: 2013-03-11
Microsoft.VisualC.CppCodeParser.OnMethodPopulateStatements(Object sender, EventArgs e)
System.CodeDom.CodeMemberMethod.get_Statements()
System.ComponentModel.Design.Serialization.TypeCodeDomSerializer.Deserialize(IDesignerSerializationManager manager, CodeTypeDeclaration declaration)
System.ComponentModel.Design.Serialization.CodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager manager)
Microsoft.VisualStudio.Design.Serialization.CodeDom.VSCodeDomDesignerLoader.PerformLoad(IDesignerSerializationManager serializationManager)
System.ComponentModel.Design.Serialization.BasicDesignerLoader.BeginLoad(IDesignerLoaderHost host)

C++ CodeDOM parser error: Line: 93, Column: 129 --- Unknown type 'AddinExpress.IE.ADXIEAdvancedBarsManager.LayoutInfo'. Please make sure that the assembly that contains this type is referenced. If this type is a part of your development project, make sure that the project has been successfully built.
Posted 11 Mar, 2013 23:19:31 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Minho,

What version of Add-in Express for IE do you use? Please try to close the iemodule designer, rebuild the project and open the designer again.
Posted 12 Mar, 2013 05:43:49 Top
minho so




Posts: 11
Joined: 2013-03-11
Hi.

visual studio 2010
ie 8

Add-in Express for Internet Explorer and .NET, Premium
Release 8.1.5065.

rebuild all the project. but the same ...
Posted 13 Mar, 2013 06:17:45 Top
Sergey Grischenko


Add-in Express team


Posts: 7187
Joined: 2004-07-05
Hi Minho,

I reproduced the issue. The fact is that 'AddinExpress.IE.ADXIEAdvancedBarsManager.LayoutInfo' type is used in some public properties of the advanced bars manager and they are marked with 'Browsable(false)'. So these properties shouldn't appear in the InitializeComponent method of the iemodule. Though they are added to InitializeComponent. It looks like a bug of the C++ component designer in Visual Studio, the C# and VB.NET designers work properly. I will try to fine a solution as soon as possible.
Posted 13 Mar, 2013 10:58:25 Top