Windows 8 IE 10

Add-in Express™ Support Service
That's what is more important than anything else

Windows 8 IE 10
 
andrew.helgeland




Posts: 51
Joined: 2012-07-20
I just tried installing my toolbar project (32-bit only) on a Windows 8 (professional 64-bit) machine. The toolbar shows up in "Add or Remove Programs," but it does not appear in Internet Explorer (10).

I checked the Add-in Express folder in {user}\Documents\ and there is only one file "adxregistrator." The log says success for everything, and the last line says "The add-in registration process is completed with HRESULT=0."

But there is no adxloader file.

Any idea how to fix this?


Here's the top of the adxregistrator.log
Installation directory: C:\Windows\Installer\
Registrator version: 8.1.5065.0
Operating System: Microsoft Professional (build 9200), 64-bit
Process Owner: Administrator
Command Line: "C:\Windows\Installer\MSI4534.tmp" /install="C:\Program Files (x86)\{Company Name}\{Company Name}Toolbar.dll" /privileges=admin /returnExitCode=false
Run 'As Administrator': No
Process Elevated: No
Integrity Level: Medium
UAC (User Account Control): On
Posted 24 Jan, 2013 11:34:33 Top
andrew.helgeland




Posts: 51
Joined: 2012-07-20
So, this problem was only the beginning...

I noticed the registrator was not running as admin, this was because I was just running the .msi and not the Setup.exe for the installer. Running Setup.exe seems to work fine.

However, now after installing my toolbar, when I enable it in IE, IE stops responding and crashes. There is still no "adxloader.log" file being created. (yes, createlogfile is set to true in the manifest)

I did notice I only have a adxloader.manifest and not an adxloader64.manifest, so I changed the name of the file. This gave me a pointer error, but the toolbar at least loaded into IE.

What am I doing wrong here?
Posted 25 Jan, 2013 14:03:25 Top
andrew.helgeland




Posts: 51
Joined: 2012-07-20
hmm.. The toolbar loads just fine if I run Internet Explorer as Administrator. ?! AND adxloader.log finally showed up in the Add-in Express folder.

adxloader needs to run as administrator? How can I fix this?
Posted 25 Jan, 2013 14:52:22 Top
andrew.helgeland




Posts: 51
Joined: 2012-07-20
Sorry, this is becoming more of just a "progress notes" thread...

I added a custom action to my installer to run IE as Administrator after the install. This gives adxloader the access it needs. Once it's run the first time, opening IE as a non-admin user works fine.

You can close this thread if no one has any other suggestions. As far as I'm concerned I've gotten it "working".

Thanks.
Posted 25 Jan, 2013 15:52:03 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Andrew,

If Protected mode is on, adxloader.log file is created in the '.\Temporary Files\Low\Add-in Express' folder.
When you run IE as Administrator, Protected mode is off automatically.
Both the adxloader.dll and adxloader64.dll files use the same 'adxloader.dll.manifest'. So there is no need to rename it.
Posted 28 Jan, 2013 07:23:31 Top