IE10 opening new tab issues

Add-in Express™ Support Service
That's what is more important than anything else

IE10 opening new tab issues
IE10 works different from older versions 
Jyry Suvilehto




Posts: 5
Joined: 2012-10-04
I'm reviewing how our plugin works on IE10 (yeah, well ahead of the last possible minute, I know...).

I discovered that when the plugin opens a new window to a certain address (it's don eon the first start of the program and goes to an SSL-secured site if it matters) then I get an "This Page Cannot Be Displayed"-message instead of the page. If I move focus to the address bar, hilight the address and press enter again then the page loads normally so I don't think there's anything wrong with the website.

Before I start to make a minimal example I thought I'd ask if this is a known feature of IE10?

For what it's worth I'm using IWebBrowser.Navigate2 with url and flags 0x01 as paramteres to open the tab/page.
Posted 04 Oct, 2012 08:35:42 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Jyry,

Please send me a link on your web site. I will test it on my PC.
Posted 04 Oct, 2012 10:29:51 Top
Jyry Suvilehto




Posts: 5
Joined: 2012-10-04
Hi Sergey,

I'll take that back. Apparently I had just installed the new version of Add-In-Express but not recompiled both the binaries and the installer so I got old behaviour. After recompiling everything said problem disappeared.

Sorry to have bothered you for nothing.
Posted 05 Oct, 2012 03:10:23 Top
Sergey Grischenko


Add-in Express team


Posts: 7202
Joined: 2004-07-05
Hi Jyry,

No problem. Let me know if you face any difficulties.
Posted 05 Oct, 2012 04:05:25 Top