adxregistrator.exe fails

Add-in Express™ Support Service
That's what is more important than anything else

adxregistrator.exe fails
adxregistrator.exe 
Yaron Avital




Posts: 22
Joined: 2011-12-01
Hi,

I'm using adxregistrator.exe to register my IE add-in

it use to work fine untill the following secnario:

At the build servr i'm compiling against .Net Framework 3.5 (Full version)
At the client machine i've installed .Net Framework 3.5 (Full version)
at this point everything worked fine.

A windows update automatically installed .Net Framework 4.0 Client profile.

at my add-in i'm using System.Web (v2.0) which not exists at Client Profile .Net versions
at this point adxregistrator.exe for some reason tries to load the latest .net framework (which is 4.0 client profile) and the registration of my add-in fails becasue it can not load System.Web from version 4.0

how can i proceed without changing the fact our clients are using .Net Framwork 4.0 client profile?

thanks,

Yaron

p.s. i've tried to attach the log of adxregistrator.exe, but i guess i've violated a rule (Message Text)
Posted 12 Dec, 2011 03:40:12 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Hi Yaron,

You just need to add a full version of .net framework to the list of prerequisites of your installer. Or, if you want to install the add-on for clients that use .Net Framework 4.0 Client Profile, you can remove it from the References of your project.
.NET, Extended MAPI, Windows Phone & RT
Posted 12 Dec, 2011 03:48:23 Top
Yaron Avital




Posts: 22
Joined: 2011-12-01
Hi Eugene,


Indeed .net framework 3.5 (full version) is a must have prerequisite at my setup,

Also i don't have a reference by any mean to .Net framework 4.0.

I've noticed that adxregistrator.exe writes the following messages to the log:



18:08:36 0152 Checking if the hosting API of .NET Framework v4.0 beta is installed.
18:08:36 0152 The hosting API is up to date.
18:08:36 0152 Calling GetInterface method for the CorRuntimeHost interface.
18:08:36 0152 Success.
18:08:36 0152 Starting CLR...
18:08:36 0152 Success.
18:08:36 0152 Getting the CLR version.
18:08:36 0152 The CLR v4.0.30319 has been initialized successfully.
18:08:36 0152 Creating a new domain setup.

how come it decided to load .NET Framework v4.0?

is there a parameter i can pass, which framework to load?
Posted 12 Dec, 2011 03:58:50 Top
Yaron Avital




Posts: 22
Joined: 2011-12-01
Hi Eugene,


Managed to get everything working again, i've found at your documentation i just needed
to pass CLR version to adxregistrator.exe


Thanks!
Posted 12 Dec, 2011 04:20:27 Top
Eugene Astafiev


Add-in Express team


Posts: 8540
Joined: 2007-07-25
Good news, Yaron!

Thank you for letting me know and good luck with your add-in project! ;-)
.NET, Extended MAPI, Windows Phone & RT
Posted 12 Dec, 2011 04:47:49 Top