A letter send problem when the delay delivery option enabled

Add-in Express™ Support Service
That's what is more important than anything else

A letter send problem when the delay delivery option enabled
 
Ruslan Plakhuta




Posts: 76
Joined: 2008-07-01
Hi All!

I have a problem with a letter send, when the "delay delivery" option enabled in Outlook 2007.
When I send a letter with this option - a font of a letter becomes non italic, the time delay constraint of delivery deleted and a letter not sending.

Steps for reproduce this problem:
1) Open Outlook 2007, create a new letter, in an opened inspector on the "Options" tab select the "Delay Delivery". In the opened dialog set "Do not deliver before" option and set time for letter deliver.

2)Create a simple addin whith the Explorer bar, the Inspector bar and the OutlookAppevent, then create 2 events: the OnItemSend and the OnExplorerSelectionChange.
In the OnExplorerSelectionChange event do some operations with email attachments (for example get attachments count) or operations with some of the MailItem interface properties (for example CC).

In case when I don`t use attachments call or the MailItem interface properties in the OnExplorerSelectionChange event - it works fine!

Windows XP SP2 and Office 2007 SP1.

If you wish I can send you this simple addin code.

Posted 02 Apr, 2009 05:27:55 Top
Dmitry Kostochko


Add-in Express team


Posts: 2739
Joined: 2004-04-05
Hello Ruslan,

Please send your demo project to us. I think it would be the best way to avoid any mistakes when attempting to reproduce the issue.


Posted 02 Apr, 2009 06:37:08 Top
Ruslan Plakhuta




Posts: 76
Joined: 2008-07-01
I have sent you letter with attached code.
Posted 02 Apr, 2009 07:02:58 Top
Dmitry Kostochko


Add-in Express team


Posts: 2739
Joined: 2004-04-05
Hello Ruslan,

Thank you for the demo project. As far as I understand the issue occurs only when you select the Outbox folder. If I am right, then this is a well-known issue, Outlook removes a "ready-to-be-sent" flag when your code gets properties from a "ready-to-be-sent" email item.

I would suggest checking the CurrentFolder property of the Explorer interface and not getting any properties in case with Outbox.

Posted 02 Apr, 2009 10:33:14 Top
Ruslan Plakhuta




Posts: 76
Joined: 2008-07-01
Hm.... bad Outglook!

Could you give me a link to this well-known issue in KB?
Posted 02 Apr, 2009 10:43:26 Top
Dmitry Kostochko


Add-in Express team


Posts: 2739
Joined: 2004-04-05
Hello Ruslan,

As far as I remember, there is no official article in Microsoft KB about this issue. But many developers have run into this.


Posted 02 Apr, 2009 11:54:32 Top
Ruslan Plakhuta




Posts: 76
Joined: 2008-07-01
I'm very grateful!
Thank you for help.
Posted 02 Apr, 2009 12:05:52 Top