CmdBar builds up very slowly

Add-in Express™ Support Service
That's what is more important than anything else

CmdBar builds up very slowly
 
Uwe Thaden




Posts: 13
Joined: 2005-03-08
In MS Word I have a CmdBar with a List a four Buttons. When I start MS Word I can see every button appear after some milliseconds. That's funny since all other baes show up at once.

What could be the reason for that?

Thanks...
Posted 08 Mar, 2005 02:46:01 Top
Dmitry Kostochko


Add-in Express team


Posts: 2740
Joined: 2004-04-05
Hi Uwe,

What value did you set to the Temporary property?
Posted 08 Mar, 2005 06:13:00 Top
Uwe Thaden


Guest


It's "False"
Posted 08 Mar, 2005 10:12:46 Top
Dmitry Kostochko


Add-in Express team


Posts: 2740
Joined: 2004-04-05
Hi Uwe,

Ok, lets try to set the FastCommandBarSearch property to true.
Please let me know about the results.


procedure TAddInModule.adxCOMAddInModuleAddInInitialize(Sender: TObject);
begin
  FastCommandBarSearch := True;


end;




Posted 08 Mar, 2005 10:29:52 Top
Guest


Guest


SAme problem: I still can see how the bar "grows" from left to right. I do not have any methods that work on the bar. Just displaying it.

Hm?

--Uwe
Posted 08 Mar, 2005 13:45:04 Top
Eugene Starostin


ADX Team
Add-in Express team


Posts: 430
Joined: 2004-04-05
Hello Uwe,

In brief... If command bars are not temporary they are created once on the add-in first start. If it is not the first start Add-in Express simply connects to controls that Word creates itself.

In any case, we will test command bars on different versions of Word and let you know about the result.
Posted 08 Mar, 2005 16:35:05 Top
Dmitry Kostochko


Add-in Express team


Posts: 2740
Joined: 2004-04-05
Hi Uwe,

We have retested the behavior of command bars with Word 2000, XP and 2003. There seems to be no difference in their behavior.

Could you please send your project to me for testing.



Posted 09 Mar, 2005 06:48:32 Top
Uwe Thaden




Posts: 13
Joined: 2005-03-08
Hi!
I'm not sure what it was. I created my project again and now it seems to work: The first build is very slow and when starting word again it is ok.

Sorry for wasting your time!

--Uwe
Posted 11 Mar, 2005 03:15:04 Top