Excel crashing down when opening file

Add-in Express™ Support Service
That's what is more important than anything else

Excel crashing down when opening file
 
Frank Jepsen




Posts: 14
Joined: 2016-07-05
Hi,

I programmed a little Excel addin providing access to a SQL database and a few utility functions. All function have been working.
But Excel is always crashing down when opening an excel file. I now removed all DB code and only some utility functions are left remaining.
I can reproduce the error by
1. Registering the addin
2. Open a new sheet
3. Type "123" in cell A1
4. Type "=AddCheck(A1)" in cell B1
5. Save an close file
6. Open it or any other excel file -> crash

The code can be found at My Webpage

Greetings
Frank
Posted 25 Jul, 2016 02:56:46 Top
Andrei Smolin


Add-in Express team


Posts: 14104
Joined: 2006-05-11
Hello Frank,

We reproduce the crash if we register your DLL. We can't reproduce it if we compile your project with Delhi XE 3.

Regards from Belarus (GMT+e),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Jul, 2016 05:13:32 Top
Frank Jepsen




Posts: 14
Joined: 2016-07-05
Many thanks for trying.
I now tried with Delphi 10 Seattle. And guess what, it worked.

Aarg!! I got a similar Problem with a XLL I tried before using Add-In-Express but the other way around (worked in XE2 but not in 10 Seattle). So I stayed with XE2 for Add-In-Express.

This costed me three days.
Do you have any idea what could cause this?
OCX/Servers are identical.

Thanks for your help
Frank
Posted 25 Jul, 2016 08:43:51 Top
Andrei Smolin


Add-in Express team


Posts: 14104
Joined: 2006-05-11
I suppose you need to install Delphi XE2 Update Pack 4 Hotfix 1.

Regards from Belarus (GMT+e),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Jul, 2016 08:56:03 Top
Frank Jepsen




Posts: 14
Joined: 2016-07-05
You are right it was the hotfix. I was on Delphi XE2 Update Pack 4. I overlooked the hotfix.
I guess it was this fix:
   Fixes error when assigning a null string to an OLE property.

After installing the hotfix it also worked with XE2.

Thanks again
Frank
Posted 25 Jul, 2016 09:28:06 Top
Andrei Smolin


Add-in Express team


Posts: 14104
Joined: 2006-05-11
Frank Jepsen writes:
I guess it was this fix:


It wasn't. They didn't mention the fix in whatsnew.

Regards from Belarus (GMT+e),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Jul, 2016 09:33:17 Top