Call does not 'happen' in adxRibbonTab2Controls

Add-in Express™ Support Service
That's what is more important than anything else

Call does not 'happen' in adxRibbonTab2Controls
testing calls inside and the first showmessage does not execute? 
Mervin Pearce




Posts: 26
Joined: 2005-12-06
I have the following code.. the 1st ShowMessage call does not execute... Any anomalies known?

procedure TAddInModule.adxRibbonTab2Controls1Controls0Click(Sender: TObject;
const RibbonControl: IRibbonControl);
var
Mail: _MailItem;
IAttachment: Attachment;
I: integer;
WorkerDir: String;
begin
frmDecrypt := TfrmDecrypt.create(self);
frmDecrypt.ShowModal;
try
WorkerDir := TPath.GetDocumentsPath+'\worker\';
ShowMessage('1:'+WorkerDir); <- Does not execute ????
ShowMessage('2:'+WorkerDir); <- Executes
ShowMessage('3:'+WorkerDir); <- Executes
ShowMessage('4:'+WorkerDir); <- Executes
ShowMessage('5:'+WorkerDir); <- Executes
......
Posted 06 Oct, 2015 08:29:20 Top
Mervin Pearce




Posts: 26
Joined: 2005-12-06
the frm.showmodal seems to be the culprit.. will investigate more
Posted 06 Oct, 2015 08:46:14 Top
Mervin Pearce




Posts: 26
Joined: 2005-12-06
The caFree on OnClose kills something it should not. Will submit as possible bug to Embarcadero.
frm.showmodal
frm.free works as designed
So I can confirm not Add-In-Express issue
Posted 06 Oct, 2015 09:36:52 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Thank you!

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 07 Oct, 2015 01:50:47 Top