Newbie question: Add-In is inactive after registration

Add-in Express™ Support Service
That's what is more important than anything else

Newbie question: Add-In is inactive after registration
 
Joachim Meyer




Posts: 7
Joined: 2015-09-24
Just learning newly purchased AddInExpress/VCL and cannot get dll registered. This is what I do:

Environment: Windows 7 and Office 2013, both 64-Bit
- starting Delphi XE8 as Administrator
- compiling "Your First Microsoft Office COM Add-in" from samples
- registering from Delphi -> registration failed
- tried again with regsvr32 as Administrator and got it registered
- Commandbar does not show
- looking at Outlook -> Options -> Add-Ins I can see MyOutlookAddin1 but it's under "Inactive AddIns"

What am I missing?
Posted 24 Sep, 2015 12:32:09 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Joachim,

Welcome on board!

Open the COM add-in dialog, check your add-in, restart Outlook and see if the add-in gets inactive again.

Make sure it's under Inactive Add-ins, not under Disabled Add-ins.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Sep, 2015 04:13:33 Top
Joachim Meyer




Posts: 7
Joined: 2015-09-24
the add-in is always in the "Inactive" section. How can I make sure that the add-in itself doesn't produce an error which prevents Outlookm from making it active?
Posted 25 Sep, 2015 04:18:14 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
First, unregister the add-in and make sure it disappears in File | options | Add-ins.

Then open the Run -> Parameters dialog box, enter regsvr32.exe into the "Host application" field, enter the name of your dll into the "Parameters" field, set breakpoints in the finalization section's code and start debugging (F9).

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 25 Sep, 2015 04:42:16 Top
Joachim Meyer




Posts: 7
Joined: 2015-09-24
add-in seems to be ok but I can't make it appear in the Active Add-Ins section of outlook. Have tried everything that came to my mind but was not successful. I'm out of ideas now.
Posted 29 Sep, 2015 04:19:37 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Joachim,

You can try commenting out block of your code and checking out if all the files are supplied. Also, open the COM add-ins dialog and click your add-in; what is written at the bottom of the dialog window?

Will a new add-in project with no code register and load with no problem?

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 29 Sep, 2015 05:09:29 Top
Joachim Meyer




Posts: 7
Joined: 2015-09-24
I created a ADX Outlook AddIn from scratch, compiled it, registered it as Administrator and Outlook still shows it as Inactive Add-In
Posted 30 Sep, 2015 05:06:43 Top
Joachim Meyer




Posts: 7
Joined: 2015-09-24
One more info: when selecting the empty add-in in the Outlook options it says "Not loaded. An error occurred while loading the COM Add-In" (translated from German)
Posted 30 Sep, 2015 05:22:56 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Joachim,

If enabling the add-in doesn't update the log file the default location of which is {user profile}\Documents\Add-in Express\adxloader.log, please check section Troubleshooting add-in loading. If this doesn't help, please let me know.

If the file gets updated, check if your add-in generates warnings or errors.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 30 Sep, 2015 06:07:39 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Joachim,

Do you have news? If you still have problems, I could access your PC remotely within the next 2 hours. Is this possible? If yes, I suggest using TeamViewer; in this case you'll need to send me your session ID and password to the support email address, find it in {Add-in Express installation folder}\readme.txt

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 30 Sep, 2015 07:28:38 Top