Outlook 2010 - ribbon disappearing

Add-in Express™ Support Service
That's what is more important than anything else

Outlook 2010 - ribbon disappearing
 
iubito




Posts: 16
Joined: 2014-06-19
Hi!
Now I'm testing my add-in in several platforms and office version.

Outlook 2007 : it works perfectly, I have my command bar in the explorer
and a ribbon tab in inspector (read / compose).

Outlook 2010 : everything is OK I have ribbon tab in the inspector (read / compose)
but in the explorer ribbon, all the tabs disappeared except "File" (fichier) and my addin.

Screenshots :
2007 : User added an image
2010 : User added an image

My addin module contains
- a TadxCommandBar
- a TadxRibbonTab
Both of them contain the same button "GED" and clicks have the same action.

I'll post just below the source.
Sylvain

DEV: Delphi 7, Win XP, Office 2007
TARGET: Win XP-7-2012 x64, Office 2007-2010
Posted 06 Aug, 2014 02:37:21 Top
iubito




Posts: 16
Joined: 2014-06-19
Sorry, the 2007 screenshot is
User added an image
Sylvain

DEV: Delphi 7, Win XP, Office 2007
TARGET: Win XP-7-2012 x64, Office 2007-2010
Posted 06 Aug, 2014 02:38:23 Top
iubito




Posts: 16
Joined: 2014-06-19
And here is the source

The ribbon tab :

object AddInModule: TAddInModule
  OldCreateOrder = True
  RegisterForAllUsers = True
  SupportedApps = [ohaExcel, ohaWord, ohaOutlook, ohaPowerPoint]
  StartFromScratch = [msrOutlookExplorer]
  StartFromScratch2010 = [msrOutlookExplorer2010]
  ...
  object adxRibbonTab1: TadxRibbonTab
    Caption = 'my company'
    Controls = <
      item
        Id = 'adxRibbonGroupF3DE34BB33DC4887B6F344CBCB102718'
        Caption = 'GED'
        Ribbons = [msrExcelWorkbook, msrPowerPointPresentation, msrWordDocument, msrOutlookMailRead, msrOutlookMailCompose, msrOutlookExplorer]
        Ribbons2010 = [msrOutlookExplorer2010]
        ControlTypes = {0100000007000000}
        Controls_ = <
          item
            Id = 'adxRibbonButton55E6AE7C7F2C4C3EB43BA6EB6882AF4A'
            Caption = 'GED Intranet'
            Ribbons = [msrExcelWorkbook, msrPowerPointPresentation, msrWordDocument, msrOutlookMailRead, msrOutlookMailCompose, msrOutlookExplorer]
            Ribbons2010 = [msrOutlookExplorer2010]
          end>
      end>
    Id = 'adxRibbonTabF6F866EA7FC147DBBB6A890F0D3E4698'
    Ribbons = [msrExcelWorkbook, msrPowerPointPresentation, msrWordDocument, msrOutlookMailRead, msrOutlookMailCompose, msrOutlookExplorer]
    Ribbons2010 = [msrOutlookExplorer2010]
  end


The command bar, special for Outlook 2007, and maybe for old 2003's but I don't care about them.

  object adxCommandBar1: TadxCommandBar
    SupportedApps = [ohaOutlook]
    CommandBarName = 'My company'
    ButtonTypes = {0100000000000000}
    Buttons = <
      item
        Caption = 'GED Intranet'
        OfficeTag = '{E5643455-EAB8-4E0D-AF8E-CC3145E50FF0}'
        olExplorerItemTypes = [adxOLMailItem]
        olInspectorItemTypes = [adxOLMail]
        PropertyChanged = 16
      end>
    PropertyChanged = 2
  end
end


Changing CommandBar UseForRibbon to true or false give the same result.

So, what is going wrong ?
Sylvain

DEV: Delphi 7, Win XP, Office 2007
TARGET: Win XP-7-2012 x64, Office 2007-2010
Posted 06 Aug, 2014 02:45:32 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
Hello Sylvain,

This is caused by StartFromScratch (StartFromScratch2010). You need to set this property to its default.

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 06 Aug, 2014 03:11:39 Top
iubito




Posts: 16
Joined: 2014-06-19
THANKS ! :)
Sylvain

DEV: Delphi 7, Win XP, Office 2007
TARGET: Win XP-7-2012 x64, Office 2007-2010
Posted 06 Aug, 2014 03:58:26 Top
Andrei Smolin


Add-in Express team


Posts: 14094
Joined: 2006-05-11
You are welcome!

Regards from Belarus (GMT+3),

Andrei Smolin
Add-in Express Team Leader
Posted 06 Aug, 2014 04:01:23 Top