Ribbon is disappearing

Add-in Express™ Support Service
That's what is more important than anything else

Ribbon is disappearing
 
Sylvain M




Posts: 16
Joined: 2014-06-19
Hi!
I'm just new to AddIn Express.
I followed the docs to create my first AddIn.
MyAddIn1 is running, it shows me "ModuleCreate" and a Task pane.
procedure TAddInModule.adxCOMAddInModuleCreate(Sender: TObject);
begin
showmessage('ModuleCreate');
end;


Before I click OK on the "show message" I can see the Excel Ribbon with the standard Excel tools.
After clicking OK the ribbon disappear, the ribbon menu is all disabled.
User added an image
Setting UseForRibbon to true or false give the same result.

I tried the doc sample MyAddIn1. I got many errors before launching but the ribbon is displayed and has a button. No effect on button.
What's going wrong with my code?
Here is my code in ZIP

Regards,

Sylvain
Sylvain

DEV: Delphi 7, Win XP, Office 2007
TARGET: Win XP-7-2012 x64, Office 2007-2010
Posted 19 Jun, 2014 09:36:05 Top
Dmitry Kostochko


Add-in Express team


Posts: 2731
Joined: 2004-04-05
Hi Sylvain,

Thank you for the detailed description and sample project.

You need to set the StartFromScratch property of your add-in module to the empty set - []. Please rebuild and retest your add-in after that.
Posted 19 Jun, 2014 09:51:28 Top
iubito




Posts: 16
Joined: 2014-06-19
Thanks for that QUICK! reply!!!

It works! \o/

Spasiba!
Sylvain

DEV: Delphi 7, Win XP, Office 2007
TARGET: Win XP-7-2012 x64, Office 2007-2010
Posted 19 Jun, 2014 10:03:00 Top